'93 Patrol Gas/Petrol

Submitted: Thursday, Nov 06, 2003 at 17:11
ThreadID: 8345 Views:2341 Replies:4 FollowUps:2
This Thread has been Archived
We have a '93 Patrol gas/petrol and have experienced a problem when towing the van, especially into a headwind. We get intermittent backfiring on gas mostly, and to a lesser extent on petrol. Also there is a miss when idling. This happens regardless of how often we have it serviced. Any help would be appreciated.
Back Expand Un-Read 0 Moderator

Reply By: GOB member vic - Thursday, Nov 06, 2003 at 18:01

Thursday, Nov 06, 2003 at 18:01
1 is it carby or fuel injected
2 electronic ignition or distributor
if it is carby and distributor it sounds like a problem i had with an 89 model got an extended rotot button from a mob in blackburn (melb ) cured the problem
this car backfired every 40ks from alice to melb

steveimagine a 03 gu 4.2tdin the picture
as i am having trouble sizing the picture
AnswerID: 36425

Follow Up By: nola - Friday, Nov 07, 2003 at 14:47

Friday, Nov 07, 2003 at 14:47
Thanks Steve,
It is carby and distributor, although we have been thinking about putting on electronic ignition as the points seem to slip as soon as they are fitted and they burn out frequently.

We have had the proper valves fitted for gas, and we use an upper cylinder lub kit, (although I don't know if my husband sets it correctly. It seems to last an awful long time without refilling!)
0
FollowupID: 26360

Follow Up By: GOB member vic - Friday, Nov 07, 2003 at 17:46

Friday, Nov 07, 2003 at 17:46
nola
definitely contact performance ignition details in a lower post talk to the gentleman there he is a font of information the extended rotor is about $50 also ask him there was something he told me to adjust (tapits or something ) he said this should be done to allow for the heat of the gas

steve

ps i think it was me who told stephen below about them and he said once before it cured his problem and our old gq never played up again after we did our rotor
imagine a 03 gu 4.2tdin the picture
as i am having trouble sizing the picture
0
FollowupID: 26371

Reply By: diamond(bendigo) - Thursday, Nov 06, 2003 at 18:12

Thursday, Nov 06, 2003 at 18:12
gday nola
another problem with patrols on gas is the valves pull into the head/valve guides wear that will cause a miss at idleback by popular demand
:-)
AnswerID: 36427

Reply By: Member - Stephen- Thursday, Nov 06, 2003 at 20:17

Thursday, Nov 06, 2003 at 20:17
hello nola,
my tb 42 did the same thing,first i tried replacing all the ignition parts ( cap ,rotor,plugs ,points,condensor)good for about 500kms than back to old problem.I finally was told about a extended rotor button (to reduce the air gap between cap & rotor) fixed problem while on petrol.Missfire still happened on gas but not as bad,for the gas problem i put a upper cylinder lube kit on( moreys )this stopped all the miss fire on gas( gas runs dry and causes the valves to stick).
I got the extended rotor from PERFORMANCE IGMITION SERVICE in Nunawading VIC 0398723644. Hope this helps.
Regards stephenjNQ.
AnswerID: 36441

Reply By: TERRY - Saturday, Nov 08, 2003 at 21:13

Saturday, Nov 08, 2003 at 21:13
nola had same problem on 89 patrol gas/ petrol tryed every think changed leads cap rotor and points still no good changed condensor ond fixed it.
sold car 12 months later person how bought car rang me 6 to 8 month latter with same problem he also change every thing with no fix and rang me i told him to change condensor and it fixed for him too
terry
AnswerID: 36630

Sponsored Links

Popular Products (13)