Jayco Camper interior roof stripping falling down

Submitted: Sunday, May 13, 2012 at 21:26
ThreadID: 95545 Views:1874 Replies:2 FollowUps:5
This Thread has been Archived
I'm hoping someone can point me in the right direction. I bought a flamingo camper and love it. Its easy for my daughter and I to handle on our own.

I noticed that the interior plastic roof stripping used to cover the interior roof joins are dropping. A friend told me to use liquid nails to hold it back up but with the heat it has dropped again.
Can anyone tell me the correct product to use as I can't stand it. It looks tacky, I can see the little staples!!

cheers Chuckie
Back Expand Un-Read 0 Moderator

Reply By: Member - There Yet - Sunday, May 13, 2012 at 21:51

Sunday, May 13, 2012 at 21:51
Hi Chuckie,

We also had the same problem with our jayco. After trying the different glues we gave up and brought new stripping. To press the new strip in you need a rubber mullet to firmly press back into joins. So far so good.

Cheers and good luck.

Kerry.
AnswerID: 485749

Follow Up By: Member - There Yet - Sunday, May 13, 2012 at 21:53

Sunday, May 13, 2012 at 21:53
Whoops, make that mallet not mullet. Although that would look funny trying to tap it back in with a fish!! lol
0
FollowupID: 760993

Follow Up By: GT Campers - Monday, May 14, 2012 at 08:53

Monday, May 14, 2012 at 08:53
or with a late-1980s rock star hair-do!
0
FollowupID: 761014

Follow Up By: David16 - Monday, May 14, 2012 at 10:03

Monday, May 14, 2012 at 10:03
Sounds like a common problem, we had a Swan O/B and same thing, i had to pull it completely off and start again as it seemed to "walk" in one direction. I never got it looking right!

David
0
FollowupID: 761022

Follow Up By: gqturbo - Monday, May 14, 2012 at 21:21

Monday, May 14, 2012 at 21:21
a clean block of wood and a hammer is all you need start one end and work across van . I worked at a dealership for a while and many vans came from the factory with the strip not fitted properly.
Brian
0
FollowupID: 761076

Follow Up By: chat2chuck97 - Tuesday, May 15, 2012 at 10:36

Tuesday, May 15, 2012 at 10:36
Thank you everyone. New stripping it is then!! No fish required LOL
0
FollowupID: 761096

Reply By: Begaboy - Monday, May 14, 2012 at 08:17

Monday, May 14, 2012 at 08:17
I have the same poptop and the same issue mine is the 2000 model outback
AnswerID: 485763

Sponsored Links

Popular Products (13)