Bit of advice nissan td42

Submitted: Monday, May 21, 2012 at 12:24
ThreadID: 95706 Views:3158 Replies:2 FollowUps:2
This Thread has been Archived
hi there
new to the site. First post,. Just picked up a 91 safari lwb hitop (patrol) td4.2 with 237k km on the clock. mint, looks to have been well loved (new brake booster, injecvtor pump done, batteries dated with changed, well in service sticker date, everything looks fine. I do not know the history (bought from auctions). Drives beauty. Only had a week, and seemed to be loosing about an inch a day (100km) in the radiator cap a day measuiring down the fill pipe going into the radiator. Also, the temp was fluctuating from cold up to about 1/4 and back down when running, stuffed thermostat. Have spotted a small rusty bleed from the top hose so changed the 2 hoses, belts, put in a hiflow 170 thermostat and new rad cap. Now runs up up to about 1/4 on guage normal, but will sneak up about 2mm on a hill, dosnt seem to rise about that, but to be fair I havnt really loaded her up. Is this normal (max it gets up to is about 1/3 if that, but the air temp herte is pretty cool). Dont seem to be losing water now, just wants to settle about 1 inch below the top of the radiator cap pipe)...thoughts?
Back Expand Un-Read 0 Moderator

Reply By: bazz - Monday, May 21, 2012 at 14:23

Monday, May 21, 2012 at 14:23
hi, had one of these myself, auto, great comfortable ride with soft hard suspension switch, most are second hand jap imports, the milage is usually wound back ,temp gauge unreliable better of putting in aftermarket, also may be 24 volt system.The 4.2 has smaller capileries in the block than other motors resulting in overheating if pushed hard, the cooling system has to be in really good condition to handle the 30 plus days towing, check the Nissan patrol forum its a wealth of information.
bazz
Patrol DX ute4.2 /Roadstar LE
AnswerID: 486391

Reply By: Witi Repartee - Monday, May 21, 2012 at 22:58

Monday, May 21, 2012 at 22:58
Hi...I have an 1989 Safari. Its a SWB, Manual. It has similar KM's to yours. My water level is the same as yours. It just blows any top up fluid out and settles back to an inch below etc. I suspect my speedo was flicked, but so far it's been totally reliable. I have driven it on a 55,000km trip around Australia and up and down the middle twice. The only major repair was a recon alternator in Cairns. I am fussy about servicing, I do the filters at every 5000km oil change. It tows well..but is not fast!!!
Here are some Patrol forums I keep an eye on and often find useful advice.
Remember the GQ is referred to as a Y60.

WA Patrol ForumInternational Patrol Forum
This forum has a Nissan section
Aussie Patrol Forum

I used to sell Jap imports in NZ...your model was popular and generally referred to as a Tokyo Ambulance because of it's internal size!

AnswerID: 486430

Follow Up By: Witi Repartee - Monday, May 21, 2012 at 23:28

Monday, May 21, 2012 at 23:28
Forgot to mention...you can download a workshop manual for Y60's from a couple of those forums. I also have a Gregorys Manual which I picked up second hand. It's Ok...but not brilliant.
0
FollowupID: 761676

Follow Up By: Mark T - Tuesday, May 22, 2012 at 05:07

Tuesday, May 22, 2012 at 05:07
Witi and Bazz, cheers for the comments, much appreciated.
0
FollowupID: 761680

Sponsored Links

Popular Products (13)