Caravan Solar Vs Inbuilt Battery Charger

Submitted: Friday, Jun 29, 2012 at 19:35
ThreadID: 96584 Views:2172 Replies:2 FollowUps:1
This Thread has been Archived
Hi Guys and Girls

I have a possible problem that I just can't get my head around. So please bear with me. My caravan has a Ctek MXS 25 battery charger and 2 x 120amp agm batteries the van also has a couple of Solar panels and a Solar regulator. Now here's the issue, when camping for a for a few days the battery voltage ranges between 13.5v in the afternoon down to 12.7v first thing in the morning on the surface that seems ok. Now when we arrive in the Caravan Park the battery voltage reads 13.5 I plug into 240v the Ctek starts charging at 25 amps but after 2.5 hours with the charge rate slows to 20amps, the battery voltage reads 14.8 volts. I would have thought at 14.8 volts the charger would be float charging not bulk charging as appears to be happening. So I just unplugged the Ctek. Thanks all in anticipation.

Peter
Back Expand Un-Read 0 Moderator

Reply By: Peter McG (Member, Melbourne) - Friday, Jun 29, 2012 at 22:53

Friday, Jun 29, 2012 at 22:53
Peter

I think you will find the Ctek charger will go to float after around 4 hours and the voltage wll be 13.6. Leave it running and check.

Peter
Peter
VKS Mobile 1906

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 489717

Reply By: MEMBER - Darian, SA - Saturday, Jun 30, 2012 at 09:03

Saturday, Jun 30, 2012 at 09:03
As I see it, you can expect the CTEK and the solar to happily work in tandem - each system assesses it's own input, according to the battery state. But the CTEK operates in modes - you get to choose one of four - on NORMAL, it simply charges as required and then floats - (I've got a bracket around mine to keep luggage away from that button - inadvertent changes to settings are known). Maybe it is on recon ? My new DC AGM's float at 14.8 on the CTEK.
AnswerID: 489730

Follow Up By: Member - Peter B6 - Saturday, Jun 30, 2012 at 16:11

Saturday, Jun 30, 2012 at 16:11
Thanks Guys
You guys are pretty much on the money, and thanks Darian my charger was on Normal but I will keep checking that on a regular basis, I guess my concern was that while I had a reading of 13.5 volts the charger was telling me the battery was at half charge. I put the charger back on 240v and 14.8 seemed to be the charge rate. All seems OK and thanks again.
Pete
0
FollowupID: 764894

Sponsored Links

Popular Products (13)