Thetford cassette toilet

Submitted: Tuesday, Mar 26, 2013 at 21:10
ThreadID: 101314 Views:1659 Replies:3 FollowUps:1
This Thread has been Archived
Hi everyone, We have recently purchased a Millard van with a Thetford cassette toilet. It was flushing really well when purchased but after a week away even though the cassette is empty and clean , it won't flush and only has a whirring sound. What are we doing wrong or not doing right. Belinda
Back Expand Un-Read 0 Moderator

Reply By: Member. Rob M (QLD) - Tuesday, Mar 26, 2013 at 21:43

Tuesday, Mar 26, 2013 at 21:43
Hi Belinda,

Could you please tell us what model of toilet is in the van.
Some work of the house water and some have a separate water tank that is separate to the main water tanks.
Hopefully it is as easy as an empty water tank.
Rob M

Lifetime Member
My Profile  My Position  Send Message

AnswerID: 507647

Reply By: WBS - Tuesday, Mar 26, 2013 at 22:09

Tuesday, Mar 26, 2013 at 22:09
It may be stating the obvious but does the top tank have water in it?
WBS
AnswerID: 507650

Reply By: baz&pud (tassie) - Wednesday, Mar 27, 2013 at 06:11

Wednesday, Mar 27, 2013 at 06:11
Sounds to me as if you may be out of water.
Open the cassette door on the side of the van, and there should be at the top a grey round "tube" with a yellow top, if there is then swing it out place some water in and problem should be solved.
If it is the latest type of toilet system where the water is drawn from the vans water tanks, can only suggest not enough water in tanks.
Hope this helps.
Cheers.
Baz
Go caravaning, life is so much shorter than death.

Lifetime Member
My Profile  My Position  Send Message

AnswerID: 507656

Follow Up By: WBS - Wednesday, Mar 27, 2013 at 09:12

Wednesday, Mar 27, 2013 at 09:12
I answered along the same lines in later thread started by the OP where they gave details on the type of Thetford it was, but that thread seems to have disappeared into the ether.
WBS
0
FollowupID: 784968

Sponsored Links

Popular Products (13)