gu3 4.2 engine management light on

Submitted: Wednesday, Mar 02, 2005 at 07:09
ThreadID: 20898 Views:1719 Replies:4 FollowUps:1
This Thread has been Archived
Hi All, Just driving to work this morning and the engine management light came on. All seems fine and even when the ignition turned off , still wont reset. Any clues. There is not a lot to manage on the 4.2 TDi. Michael
Patrol 4.2TDi 2003

Retired 2016 and now Out and About!

There's time to rest when you're dead,
Get out and do something instead!

Member
My Profile  My Blog  My Position  Send Message

Back Expand Un-Read 0 Moderator

Reply By: Member - Sand Man (SA) - Wednesday, Mar 02, 2005 at 07:24

Wednesday, Mar 02, 2005 at 07:24
I would guess you have a faulty sensor, or even more likely, a loose connection in one of the sensor cables.

I had this problem in the Jack recently. Was eventually identified by a diagnostic computer. These modern vehicles are getting beyond the basic maintenance capabilities of us mere mortals.
Bill


I'm diagonally parked in a parallel Universe!

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 100759

Reply By: Brian B (QLD) - Wednesday, Mar 02, 2005 at 09:12

Wednesday, Mar 02, 2005 at 09:12
Hi Michael,

I think the only safe way to go though is to get it looked at as that indicator is designed to let you know that something may not be quite as it should be.

Unfortunately unless it is an obvious fault then it becomes a specialist job to find out what is wrong.

Hopefully it is just a minor thing hey?

Cheers

Brian
AnswerID: 100765

Reply By: Willem - Wednesday, Mar 02, 2005 at 09:49

Wednesday, Mar 02, 2005 at 09:49
My engine management system light and beeper kept coming on and I couldnt find the fault. The beeper in particular was very annoying so in desperation I disabled it. Only when I got home and was crawling around under the truck, that I found that the winch cable was shorting out on the chassis.
AnswerID: 100773

Reply By: Michael ( Moss Vale NSW) - Wednesday, Mar 02, 2005 at 10:36

Wednesday, Mar 02, 2005 at 10:36
Thanks guys, I just rang Nissan Liverpool, my dealer, they said , not too much connected to this in the 4.2tdi, said it could be water in the fuel filter. They said just drop in in on the way home and they will check and reset the alarm.. Anyone out in the southwest needs Nissan sales and or service, these guys are terriffic. Nothing is a problem to them. Been dealing with them for 6 years and no problems.. Michael.
Patrol 4.2TDi 2003

Retired 2016 and now Out and About!

There's time to rest when you're dead,
Get out and do something instead!

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 100776

Follow Up By: Member - Michael- Wednesday, Mar 02, 2005 at 10:58

Wednesday, Mar 02, 2005 at 10:58
I was going to say that it sounds like it is your fuel filter, contamination or blockage can trigger off engine light
May the fleas of a thousand afghan camels infect the crutch of your enemy and may their arms be too short to scratch.

Lifetime Member
My Profile  Send Message

0
FollowupID: 358909

Sponsored Links

Popular Products (14)