Toyota 75 78 owners

Submitted: Tuesday, Feb 14, 2006 at 15:35
ThreadID: 30778 Views:1259 Replies:8 FollowUps:2
This Thread has been Archived
Hi all

Has anyone had any problems with the clutch in the turbo models?

I know a bloke over here (WA) that has just had the clutch replaced (slipping) at 67000km 2004 model 78 RV troopy

he always complained of the clutch peddle being to high

my peddle seems high but thats the way it was from the start, I have not had any problems with mine so far, only a couple of weeks ago had to drive up some 1:1 jump ups in 1st low and was ok

Yours is a 2003 model 78 RV troopy with 66000km on the clock

just would like to know if anyone has any problems

Regards

Richard
Back Expand Un-Read 0 Moderator

Reply By: Member - Phil G (SA) - Tuesday, Feb 14, 2006 at 16:20

Tuesday, Feb 14, 2006 at 16:20
90,000km - no problems
AnswerID: 154923

Follow Up By: Richard Kovac - Tuesday, Feb 14, 2006 at 16:28

Tuesday, Feb 14, 2006 at 16:28
Thanks Phil
0
FollowupID: 408910

Reply By: Member - Luxoluk - Tuesday, Feb 14, 2006 at 16:32

Tuesday, Feb 14, 2006 at 16:32
Early days (05 model) and no hint of any problems, even under duress. Having said that she'll probably do a spit next week!! Cheers
AnswerID: 154924

Reply By: DesC - Tuesday, Feb 14, 2006 at 18:12

Tuesday, Feb 14, 2006 at 18:12
Dendle's @ Springsure have replaced a heap of turbo ute and wagon clutches i believe.
AnswerID: 154943

Reply By: Wayne (NSW) - Tuesday, Feb 14, 2006 at 18:13

Tuesday, Feb 14, 2006 at 18:13
Richard,

216,000 klm with a high clutch pedal. After market turbo. Still going strong.

Wayne
AnswerID: 154944

Reply By: Member - John (Vic) - Tuesday, Feb 14, 2006 at 19:06

Tuesday, Feb 14, 2006 at 19:06
72,000 Kms here Richard no worries all good.

VKS737 - Mobile 6352 (Selcall 6352)

Lifetime Member
My Profile  My Position  Send Message
Classifieds: Water Tank 55 Litre

AnswerID: 154960

Reply By: Member - Ozdyssey (QLD) - Tuesday, Feb 14, 2006 at 23:37

Tuesday, Feb 14, 2006 at 23:37
Richard
60k turbo - no probs

clutch pedal doesn't feel high to me.

John
AnswerID: 155048

Reply By: Bob Y. - Qld - Wednesday, Feb 15, 2006 at 22:01

Wednesday, Feb 15, 2006 at 22:01
Richard,

135K in a 79 series turbo, with no dramas. Gearbox is a bit notchy in first though.

Hooroo...
Seen it all, Done it all.
Can't remember most of it.

Lifetime Member
My Profile  My Blog  My Position  Send Message

AnswerID: 155233

Reply By: Richard Kovac - Thursday, Feb 16, 2006 at 00:25

Thursday, Feb 16, 2006 at 00:25
Thank you all

I will sleep better now

I must admit that the other bloke was a ex Nissan drive a patrol I think LOL.

Richard
AnswerID: 155269

Follow Up By: DesC - Thursday, Feb 16, 2006 at 19:32

Thursday, Feb 16, 2006 at 19:32
I have a lot of mates on stations in that area who are Tojo mad and who own heaps of them. I Lived in the Central Highlands for many years. They are the people that told me about the clutch problems so you should give Dendle's a ring old mate and ask him the question.
0
FollowupID: 409395

Sponsored Links

Popular Products (13)