Engel Fridge

Could anyone please give me any advise on my 60L Engel Fridge/Freezer, just stopped working on 240v works fine on 12v. Is nearly 5 years old. Any help appreciated.
Back Expand Un-Read 0 Moderator

Reply By: Member - Scoot (SA) - Wednesday, Mar 31, 2010 at 22:45

Wednesday, Mar 31, 2010 at 22:45
get your 240 lead tested.

My 12volt lead for my frig was faulty after many years of service.
Got a new one and it's been OK ever since.

Cheers Scoot . :-)
AnswerID: 411247

Reply By: oldtrack123 - Wednesday, Mar 31, 2010 at 23:35

Wednesday, Mar 31, 2010 at 23:35
HI Shane
The first step is to get the Engel 240v lead checked ,could be a broken wire
AnswerID: 411250

Follow Up By: Sand Man (SA) - Thursday, Apr 01, 2010 at 07:05

Thursday, Apr 01, 2010 at 07:05
Or a blown in-line fuse.

Bill


I'm diagonally parked in a parallel Universe!

Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 681349

Follow Up By: Alloy c/t - Thursday, Apr 01, 2010 at 09:08

Thursday, Apr 01, 2010 at 09:08
No inline fuse on the 240v lead ,dooh,
0
FollowupID: 681353

Follow Up By: Member - The Crow (QLD) - Thursday, Apr 01, 2010 at 20:55

Thursday, Apr 01, 2010 at 20:55
Get the Polly fuse checked mine went, it is too small. The new 60ltrs get a bigger fuse. The fuse is about $25 but it cost around $140 to get it fitted that was in 08 and in Mount Isa and it is still going strong it was just out of warranty. It was fixed in about a hour and a half. We were passing through the Isa at the time.
200 Series V8 Diesel
Thanks for the Rest Flying West and Flying Very Low along the track not coming back. The Crow

Lifetime Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 681423

Sponsored Links

Popular Products (14)